Knowledgebase
AGT, Inc. > Help Desk > Knowledgebase

"Initializing VBA System... Execution errordone"

Solution

Applies to:

Legal-Aid 2007 to 2010

 

Issue:

When starting Legal-Aid, you get a VBA Execution Error as shown in the command line image below.

Initializing VBA System... Execution Error Done

 

Cause:

This is normally caused by installing Legal-Aid with the Civil 3D option enabled when Civil 3D is not actually installed on the computer.  (Note that Civil 3D Companion is not the same thing as Civil 3D).  This can also be caused by having more than one copy of the same version of Legal-Aid on your computer.  Note that it is okay to have several different versions of Legal-Aid installed, but not multiple copies of the same version.

 

Solution:

First, try the following:

  1. Reinstall Legal-Aid (Important - do not uninstall Legal-Aid, just reinstall over it)
  2. When asked if Civil 3D is installed on this computer, select No.

 

Now start AutoCAD and then try Legal-Aid. If the issue is still present, then try manually removing all copies of Legal-Aid from your computer and then reinstalling it.

  1. Do a complete search of your computer for the file 'LA2012.dvb' (or the version that you are using, such as LA2010, LA2011 etc.)
  2. For each occurrence that you find delete the LA2012.dvb files. When finished, there should be no more la2012.dvb files anywhere on your computer.
  3. Reinstall Legal-Aid.

 

If you find multiple installations, you may wish to simply delete each of the entire installations. You can do so without harm. For all newer versions of Legal-Aid, the phrase libraries are stored in a separate location from the program files and won't be deleted if you delete the program folder. Before deleting the folder, double check that no *.plb files are present and back them up to a temporary location if they are.

 
 
Was this article helpful? yes / no
Article details
Article ID: 6
Category: Legal-Aid
Date added: 2012-01-24 08:46:13
Views: 1114
Rating (Votes): Article rated 3.5/5.0 (31)

 
<< Go back

 
Powered by Help Desk Software HESK - brought to you by Help Desk Software SysAid